Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: WCF Solutions Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

Donnerstag, 6. Februar 2014, 03:26

Zusatzfelder Standardwert Text

Moin,

ist das möglich das man sich das selber so umbauen kann, das der Standardwert Text von den Zusatzfeldern im Hintergrund Angezeigt wird?
Derzeit ist das ja so, wenn man das Feld zb. nicht Ausfüllt und dort ist ein Standardwert Text, dann wird dieser so Übernommen.

Um den Standardwert Text für mich Gut nutzen zu können, würde ich das gerne so haben das der Text im Hintergrund nur Angezeigt wird ohne das er Übernommen wird bei nicht Ausfüllen.

Das wäre zb. auch für User einfacher, da sie beim drauf klicken gleich ein Leeres Feld vor sich haben ohne einen Text den sie erstmal Löschen müssen. ;)

Gruß

2

Donnerstag, 6. Februar 2014, 12:23

mit placeholder-Attribut würde es gehen ;)

3

Freitag, 7. Februar 2014, 23:54

Danke, ich werde mir das bei Gelegenheit mal Anschauen.
Aber was Google mir in der Hinsicht Ausgespuckt hat, hört sich sehr Vielversprechend an. ;)

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »zeromatick« (8. Februar 2014, 01:05) aus folgendem Grund: Edit in eigenen Post


4

Samstag, 8. Februar 2014, 01:05

Habe mir das eben mal Angeschaut, aber nur die Einträge gefunden für die Einträge Ansicht gefunden aber nicht für die vom Erstellen.
Hat da jemand für mich eine kleine Hilfe, damit ich das finde? (Mit einer kleinen Hilfe Suche ich mir das auch gerne selber raus.)

5

Dienstag, 18. Februar 2014, 16:12

Ich mache ungerne Doppelposts und Pushe was, aber hier scheint sich ja nix zu rühren.

Ich bin über jede Hilfestellung sehr Dankbar!
Damit ich die Einträge mal finde zum Ändern, weil so wie es derzeit ist geht es einfach nicht das dort ein Text drin steht den man erstmal Löschen muss. ;)

Gruß

MysteryCode

Senior Mitglied

Wohnort: München

Beruf: Webmaster

  • Nachricht senden

6

Dienstag, 18. Februar 2014, 18:26

Am besten siehst du dir mal Zeile 152 in der entryAdd.tpl an. :)

statt value schreibst du nun placeholder.
Danach sollte dann dort folgendes stehen:

Quellcode

1
placeholder="{$fieldValues[$field->fieldID]}"
http://update.mysterycode.de/maelstrom/
http://update.mysterycode.de/typhoon/

7

Dienstag, 18. Februar 2014, 19:09

Vielen Dank, das war die Lösung. :)
Ich meine ich war auch in dem tpl schon Unterwegs aber irgendwie habe ich da wohl was Falsch Eingetragen gehabt.

Jetzt nur noch die Farbe Anpassen, und dann ist die Geschichte Perfekt.

8

Dienstag, 25. Februar 2014, 01:51

Sorry für Doppelpost.

Aber mir ist grade ein Fehler mit der Einstellung Aufgefallen.
Und zwar sind die Felder wenn man ein Eintrag bearbeitet so gesehen Leer, man muss diese Zwingend Ausfüllen wieder, was man vorher dort reingeschrieben hat wird aber im Background Angezeigt.

Jemand ne Idee, oder muss Sebastian was am System Ändern damit man dies beheben kann? :(

MysteryCode

Senior Mitglied

Wohnort: München

Beruf: Webmaster

  • Nachricht senden

9

Dienstag, 25. Februar 2014, 08:13

Das ist der Nachteil daran.
Wenn man den Standardwert abfragen könnte, könnte man das leicht ändern.
Ich weiß nicht, ob das funktioniert, aber man könnte auch {if $action == 'add' } placeholder... {else} value... {/if} versuchen.
http://update.mysterycode.de/maelstrom/
http://update.mysterycode.de/typhoon/

10

Dienstag, 25. Februar 2014, 18:46

Danke dir.
Ich Versuche das nachher oder Morgen mal, ob das damit hinhaut.