Sie sind nicht angemeldet.

1

Montag, 27. November 2017, 09:25

Filebase 3 Undefined offset wcf/templates/compiled/9_wsif_1_category.php (3525): Undefined offset: 727

Hallo,

nachdem wir leider per E-Mail keine Antwort erhalten, versuchen wir es nun auf diesen Weg.

Wir haben einige Einträge verschoben, nun haben wir das Problem, das unser Filebase "spinnt"

In den Kategorien sieht das wie folgt aus, siehe Bilder und im ACP bekommen wir Fehlermeldungen.

Es wäre sehr schön, wenn die Filebase bald wieder ihren Dienst verrichten kann. Den es werden keine Einträge mehr angezeigt.

WCF Version 4.1.17
Filebase Version 3.1.1 pl1

Vielen Dank im Voraus für die schnelle Hilfe.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Mon, 27 Nov 2017 00:40:43 +0000
Message: PHP notice in file /var/www/clients/client1/web5/web/wcf/templates/compiled/9_wsif_1_category.php (3525): Undefined offset: 727
File: /var/www/clients/client1/web5/web/wcf/lib/system/WCF.class.php (309)
PHP version: 5.6.30-0+deb8u1
WCF version: 2.1.19 (Typhoon)
Request URI: /wsif/index.php/Category/6-Diesel/?sortField=time&sortOrder=DESC&tagID=667
Referrer: 
User-Agent: Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)
Information: ""
Stacktrace: 
  #0 /var/www/clients/client1/web5/web/wcf/templates/compiled/9_wsif_1_category.php(3525): wcf\system\WCF::handleError(8, 'Undefined offse...', '/var/www/client...', 3525, Array)
  #1 /var/www/clients/client1/web5/web/wcf/lib/system/template/TemplateEngine.class.php(323): include('/var/www/client...')
  #2 /var/www/clients/client1/web5/web/wcf/lib/page/AbstractPage.class.php(305): wcf\system\template\TemplateEngine->display('category', 'wsif')
  #3 /var/www/clients/client1/web5/web/wcf/lib/page/AbstractPage.class.php(100): wcf\page\AbstractPage->show()
  #4 /var/www/clients/client1/web5/web/wcf/lib/system/request/Request.class.php(58): wcf\page\AbstractPage->__run()
  #5 /var/www/clients/client1/web5/web/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()
  #6 /var/www/clients/client1/web5/web/wsif/index.php(17): wcf\system\request\RequestHandler->handle('wsif')
  #7 {main}
»RSN« hat folgende Dateien angehängt:
  • Eintrag1.PNG (114,22 kB - 4 mal heruntergeladen - zuletzt: 9. Januar 2018, 15:47)
  • acp1.PNG (69,64 kB - 3 mal heruntergeladen - zuletzt: 27. November 2017, 23:54)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »RSN« (27. November 2017, 09:57)


2

Montag, 27. November 2017, 11:53

Ergänzung: Offensichtlich liegt es daran, wenn man mehrere Unterordner / Unterkategorien erstellt, dass es dann zu dieser o. g. Fehlermeldung kommt.
Also z. B. wie auf dem Bild "Rollmaterial-Repaints-Loks" und dann die Kategorie "BR101EL" usw. - dann geht nichts mehr.

Wir bitten um dringende Abhilfe, denn ohne ausreichende Kategorisierung geht die Übersicht komplett verloren.

Vielen Dank!
»RSN« hat folgende Datei angehängt:

3

Montag, 27. November 2017, 23:55

Benutzt du Eintragsfelder (ich koennte mir vorstellen, dass es damit evtl. beim Verschieben Probleme gibt)? Ausserdem, welche Fehler gibt es im ACP?